Sympl-web package missing for ARM / Raspberry Pi

Continuing the discussion from Sympl-web-configure not found:

Problem Description

After following the latest and greatest install instructions from Installing Sympl - Sympl Wiki on a Raspberry Pi, the webserver portion of sympl is missing.


“It’s available now for Debian Stretch, Buster and Bullseye at no cost, and will run happily on Dedicated or Virtual servers, and even the Raspberry Pi.”

It looks like sympl-web is still not available for Bullseye on ARM / Raspberry Pi.
From what I can see from Index of /mythic/pool/main/s/sympl-web the packages simply aren’t being built.

Any Error Messages

$ uname -a
Linux 6.1.19-v8+ #1637 SMP PREEMPT Tue Mar 14 11:11:47 GMT 2023 aarch64 GNU/Linux
$ cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"
VERSION="11 (bullseye)"
$ sudo apt list --installed sympl*
sympl-backup/bullseye,bullseye,now 11.20210818.1 all [installed,automatic]
sympl-core/bullseye,bullseye,now 11.20220426.0 all [installed]
sympl-dns/bullseye,bullseye,now 11.20210818.1 all [installed,automatic]
sympl-ftp/bullseye,bullseye,now 11.20210818.1 all [installed,automatic]
sympl-mail/bullseye,bullseye,now 11.20220929.0 all [installed,automatic]
sympl-monit/bullseye,bullseye,now 11.20210818.1 all [installed,automatic]
sympl-mysql/bullseye,bullseye,now 11.20210818.1 all [installed,automatic]
sympl-phpmyadmin/bullseye,bullseye,now 11.20210818.1 all [installed,automatic]
sympl-updater/bullseye,bullseye,now 11.20210818.1 all [installed,automatic]
sympl-webmail/bullseye,bullseye,now 11.20220322.0 all [installed,automatic]
$ sudo apt install sympl-web -y
Reading package lists...
Building dependency tree...
Reading state information...
Package sympl-web is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source


  • Sympl Version: 11, see above
  • Sympl Testing Version? No
  • Debian Version: bullseye
  • Hardware Type? Pi
  • Hosted On?: local network

For now, there are only packages for Debian 10 (buster) on armhf (32 bit) on the Mythic Beasts repo, and this is a known issue at the moment.

The packaging for the Pi binary packages is broken currently, but it’s being looked into.

Thanks. It’s good to hear it’s being looked at.
Do you have any rough idea of how long it may take to fix? Are we talking days, weeks, months or next year sometime? I realise it is often difficult to say but a vague idea of how high it is up the priorities would be useful

Thanks again for all the hard work you and the whole team put into software like this, it is appreciated.

Honestly hard to say - there’s quite a few moving parts to build, compile, package, sign and add to the repository.

I think I found the area where it’s breaking. But it’s not something I’m that familiar with, and I need to get someone who’s a little more familiar to lok into it when available.

1 Like

You mean you’re sticking to doing things you’re competent at, and getting expert help when necessary? You’ve no chance of a post in the government, then!

Seriously, your work on this is appreciated. I’d like to install it on PI4, especially as it’s possible to buy them again.


Just adding my voice to the appreciation. I’m intending to buy a Pi 4 as a small web server, and sympl makes that much easier.

I used symbiosis back in the day, and was gutted when I discovered it had been abandoned. Until I discovered it had been forked into sympl :slightly_smiling_face:

1 Like

There used to be a Sympl Pi4 setup in the past. Is it not possible to publish that again?

IIRC, those were 32 bit packages for Buster, which are still fine, but the Bullseye/Bookworm ones aren’t able to be built at the moment.

I have a theory I’ll test out in the next few days if I can, though…

Theres a new architecture-independent version of sympl-web on the bookworm-unstable branch currently.

I’ve moved from a pre-compiled version of sympl-web-logger (the process which takes the piped apache logs and writes them in the relevant /srv/ directory) to be compiled at install, which only takes a few seconds and has a small list of extra dependencies.

It’s not been tested properly, and there are still missing sympl-cron and sympl-firewall packages, but it should be enough to verify and get a working version of Sympl on a Pi running PiOS Bookworm (in both 32bit and 64bit flavours).

Assuming all is okay, I’ll replicate these changes with sympl-cron and sympl-firewall, and back-port them to Buster and Bullseye, and the missing packages should then finally be available!

Quick update… A Pi-compatible sympl-web is on the testing repo now for Bookworm, and a matching one for sympl-firewall should be joining in an hour or two it as it works though the CI and packaging process.

There’s still sympl-cron to do as well, but that should be fairly rapid, then it’s a case of manually confirming these all work as expected, and back-porting the changes to older Debians.

sympl-cron is now architecture-independent, meaning Sympl Bookworm (on the testing branch) can now be run on Raspberry Pi in 32 and 64 bit flavours, as well any other architecture you can run Debian on!

This will need some more testing before it’s backported and pushed to stable, but I’m reasonably certain it should work fine.

1 Like

This is excellent news :smile:

The testing branches for buster, bullseye and bookworm now all have Pi-compatible versions!

Install as normal, but use bash --testing - you can swap to the stable branch directly after (running it again without the testing switch), and you’ll then just have the new changes and a regular install.

I’ll do some testing on armhf, arm64 and amd64 over the next few days, but I don’t expect any issues.

There will be a post in the news section when it goes live.


That is excellent new and thank you for your work on this. It looks like things are almost resolved.

Unfortunately though I’ve just tried to install it on Bullseye (from testing) but still can’t see the sympl-web package on the server. Neither is sympl-firewall playing ball.

christopher@25:~ $ sudo apt update
Hit:1 bullseye-security InRelease
Hit:2 bullseye InRelease               
Hit:3 bullseye InRelease      
Hit:4 bullseye-testing InRelease
Hit:5 bullseye-updates InRelease       
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
christopher@25:~ $ sudo apt install sympl-web sympl-cron sympl-firewall
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package sympl-web is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'sympl-web' has no installation candidate
christopher@25:~ $ sudo apt list sympl*
Listing... Done
sympl-backup/bullseye-testing,bullseye-testing,now 11.20210818.1 all [installed,automatic]
sympl-core/bullseye-testing,bullseye-testing,now 11.20220426.0 all [installed]
sympl-cron/bullseye-testing,bullseye-testing 11.20231018.0 all
sympl-cron/bullseye-testing 11.20210818.1 armhf
sympl-dns/bullseye-testing,bullseye-testing,now 11.20210818.1 all [installed,automatic]
sympl-firewall/bullseye-testing 11.20210818.1 armhf
sympl-ftp/bullseye-testing,bullseye-testing,now 11.20210818.1 all [installed,automatic]
sympl-mail/bullseye-testing,bullseye-testing,now 11.20220929.0 all [installed,automatic]
sympl-monit/bullseye-testing,bullseye-testing,now 11.20210818.1 all [installed,automatic]
sympl-mysql/bullseye-testing,bullseye-testing,now 11.20210818.1 all [installed,automatic]
sympl-phpmyadmin/bullseye-testing,bullseye-testing,now 11.20210818.1 all [installed,automatic]
sympl-updater/bullseye-testing,bullseye-testing,now 11.20210818.1 all [installed,automatic]
sympl-webmail/bullseye-testing,bullseye-testing,now 11.20220322.0 all [installed,automatic]
christopher@25:~ $ sudo apt install sympl-firewall
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sympl-firewall:armhf : Depends: ruby:armhf (>= 1:2.7~0) but it is not going to be installed
                        Depends: sympl-core:armhf but it is not installable
                        Depends: libruby:armhf but it is not installable
                        Depends: ruby-sqlite3:armhf but it is not going to be installed
                        Depends: ruby:armhf (< 1:2.8~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I’ve just pushed some fixes now for Bullseye, so there should be proper ‘all’ packages now, but I’ve not tested on arm yet.

I’ve managed to test buster (and fix it) and bullseye on arm, both 32 and 64 bit, and they all checked out okay.

I want to test Bookworm as well (quite a few changes there to test), but should have that done in the next few days.


Excellent. Thank you again!
I’ve now marked this as solved.

Just to note I also ran into the SSL stapling issue when testing bullseye, but I see you’ve already resolved that before I got round to investigating it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.