Web / ssl configure failed

Problem Description

Adding a www. to a site seems tro have generated an error

Any Error Messages

Error executing script for live-update event
/etc/sympl/ssl-hooks.d/sympl-ftp exited with status 1
Job for pure-ftpd.service canceled.


  • Sympl Version [10.0]:
  • Sympl Testing Version? [No]
  • Debian Version [Buster]:
  • Hardware Type? [Dedicated]
  • Hosted On? [bytemark]

There’s a bit more to it than that, though.

After moving between servers, a few people have reported not receiving any emails. I have noticed that these are all accounts that don’t have a website.

There is a public/htdocs/index.html but they haven’t had an a record set up for their domain. Could that have a bearing on why no email is arriving?

Possibly a silly question, but have the MX records been updated?

As far as the sympl-ftp hook goes, all it does is restart pure-ftpd, so you may have problems with your SSL certs.

sympl-ssl --verbose and sympl-web-configure --verbose should give some hints.

I reckon I’ve worked out what the problem is, but not why the problem is.

Although there are well over a hundred different domain accounts on the server, only three or four (well, I can only think of four) that are email-only, no website at all.

For those, I didn’t set up a www. A record in the DNS. Don’t need one if you don’t have a website, do you? They did all have a public/htdocs folder because I guessed that was needed to get a SSL certificate. And a simple index.htm that said something like “hello”

Well, all seemed to go according to plan, except that none of these four accounts was getting any incoming email. None at all. They could send, but not receive.

So when I realised the common factor, I added the www A DNS record and force recreated the website and the SSL. Made no difference.

So I moved their entire /srv directory away to a safe place, deleted their sites-enabled and sites-available records, re-ran sudo sympl-web-configure (just to stamp on the site’s grave)

Then sympl create web domain.co.uk nano /srv/domain.co.uk/public./htdocs.index.htm
Thensudo sympl-web-configure and sudo sympl-ssl
Add the maildir/username directory.
Send an email, and it arrives!

Copied the moved-way mailbox contents in and they seem to be OK again.

I’m pretty sure there is something fundamental wrong with the setup if there is no www A record.

I have a suspicion that the webmail directory wasn’t set up either, but I was too focused on getting their email fixed that I didn’t investigate properly. Sorry.

Later: remembered a fifth. Yup, no webmail before I fixed it.

The mx records were pointing at the domain, not changed for the move. And they’re unchanged after the fix. All I did is add an a record for www and remake the entire account.

I’ve found another failure case for this.

Create a working domain, say domain.co.uk, with DNS A pointing to the IP

When sympl-ssl runs, it successfully verifies domain.co.uk and www.domain.co.uk

Create /srv/domain.co.uk /mailboxes/test and immediately, test@domain.co.uk works as an email address.

Now do the same with sub.domain.co.uk, also with an A record pointing the the IP

When sympl-ssl runs, it validates [sub.domain.co.uk] but fails to verify [www.sub.domain.co.uk]

Create /srv/sub.domain.co.uk/mailboxes/test and email to [test@sub.domain.co.uk] doesn’t arrive. No Maildir is created, nothing.

I’ll see if I can replicate this - sounds like maybe the mail is being caught somewhere.

Did this ever reach resolution? Were you able to replicate the problem?

Just checked it now, and mail is received as expected on both Buster and Stretch versions.

I’d suggest checking there’s an MX record for the subdomain.example.com site as the sending server may be picky, but it works for me with only a plain CNAME which lead to an A/AAAA record.

Now you’ve confirmed that it should work, I’ll try some more. Thanks.