"Unrouteable address" error in exim4/mainlog for mailbox(es) that exists - only affecting a specific domain/site

Problem Description

I’ve got a domain, let’s call it example.com, that refuses to accept mail for its uses - giving a “Unrouteable address” error in the exim4/mainlog for any attempts (although sending a local email “sendmail user@example.com” does appear to work. The mailboxes are quite large but previously worked on Symbiosis before being migrated to Sympl on AWS. Other mailboxes on different domains on the same server do work, I’ve tried creating a new mailbox on the affected site/domain and that doesn’t work.

Any suggestions?

Any Error Messages

(email addresses masked)

2019-11-18 14:05:14 H=mail-eopbgr50050.outbound.protection.outlook.com (EUR03-VE1-obe.outbound.protection.outlook.com) [] X=TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256 CV=no F=<sender@example.net> rejected RCPT <user@example.com>: Unrouteable address


  • Sympl Version 9.0
  • Debian Version Stretch
  • Hardware Type? Virtual
  • Sympl Testing Version? No

Answering my own question but might be useful for others.

For some reason the main site folder “example.com” in this case, had permissions set to 744 - after setting permissions to 755 (as the other site folders were) email delivery went back to normal.

Not sure why the site folder for this specific site was set to 744 but problem solved now :slight_smile: