Symple Debian 12 webmail upgrade issues

I’ve recently upgraded from Sympl 11 to Sympl 12 and all appeared to go well.

I almost never use webmail so didn’t test that. But on trying yesterday I found the following.

Access is not available from all domains as it was before. Only the first domain works

so works

but does not

Next is the logon page. That is now insisting on the server name being entered as well as username and password. Localhost works fine but it seems I will need to edit the roundcube configuration to remove that field.

There’s an ‘imap_host’ setting which is configured as an empty string, which causes the server name field to be included in the login form. The config value can be set to ‘localhost’ (suggestion ftrom another forum, which worked for me).

Thanks. If it is the same post I found it was from 2013 so the structure has changed a bit. I will spend some time looking later as my day job is getting in the way this week. Does also seem odd that phomyadmin access works from alll domains but webmail doesn’t since the upgrade. I’ll have to investigate that a bit deeper too

Yes, that’s the one, on the roundcube forum.
It called it ‘default_host’ then, but it’s ‘imap_host’ now, in the file

I noticed that /var/lib/roundcube/config/ has a setting to set it to localhosts if not defined, but it’s referring to 'default_host' instead of 'imap_host' - which I’ve just noticed, and explains why it doesn’t work.

Ah, good work tracking that down - it looks like the isn’t updated once it’s created, so the old version would stick around with the out-of-date variable.

This should fix it for anyone affected:

sudo sed -i "s|'default_host'|'imap_host'|g" /var/lib/roundcube/config/

And I’ll update the upgrade documentation now.

@phill104, can you try that and confirm if it fixes it?

Thanks to you both. That does indeed fix the variable.

Now I just have to work out why webmail only works from one domain. All other domains on my setup give a “No input file specified.” error. I am sure that is just my setup though