Roundcube fails importing contact list

I was initially trying and failing to import a Roundcube contacts list (VCF) from an earlier version of Roundcube as part of a site migration. Eventually I found that Roundcube webmail as installed with Sympl cannot even import a simple contacts list that it has just exported itself!
I got a log file message "Maximum number of allowable file uploads has been exceeded " when attempting the import.

Could this have something to do with the Sympl Roundcube configuration?
Directory permissions?

  • Sympl Version 10.0
  • Debian Version Buster
  • Hardware Type? Virtual
  • Sympl Testing Version? No

I’d suspect it’s to do with the php config that’s limiting it. Do the Apache or PHP logs reveal any more info about the error?

The message I quoted was the only log entry that seems to relate, in
the domain’s public/logs/ssl_error file.
The config for Roundcube under Sympl is quite convoluted, with symlinks all over the place, but as far as I can make out:

  • max_file_uploads isn’t overridden anywhere
  • temp directories are writable by www-data (I thought that might provoke the error, even though the message doesn’t describe it well)

(edited to add) Also I tried sending myself an email with a file attachment, and file uploads, at least for that purpose, work fine. So it’s more specific to the contacts list.

Found the problem!

While uploads for attachments are fine, the contacts list (and likely any other import/export plugin like stuff) defaults to the PHP upload_tmp_dir value, which is /srv/, which is fine for the regular sites hosted, but as roundcube is aliased, it breaks as it can’t access the file which was uploaded.

I should have fix for sympl-webmail pushed out soon to the testing branch, and I’ll fast-track it to stable.

1 Like

Thank you! I’m glad I persisted with this, and hope a new customer (affected by this) will appreciate it too!

P.S. is there a temporary fix, by editing a config file somewhere?

Yes, edit /etc/apache2/conf-enabled/sympl-webmail.conf, and make the change in this commit, effectively adding the line:

php_admin_value upload_tmp_dir /var/lib/roundcube/temp # No longer needed, see below.

before the </Directory> statement.

Once that’s done, reload Apache with sudo service apache2 reload and you should be good to go.

The fix is in the testing branch now, and once the tests have passed again, I’ll push it to stable, along with the roll up of a number of other fixes from testing.

This fix has now been pushed to both the stable and testing branches, and will be automatically installed over the next day or two, otherwise you can run sympl update manually to install the updated version immediately.


Fix installed and working. Impressive!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.