PHP 7.4 EOL - New Sympl Version to upgrade to PHP 8 / 8.1

Hi all! I have tried searching the form but to no avail so im sorry if indeed this is a “repeat post”

I was wondering if Sympl will be upgrading to v12 anytime soon as support for PHP 7.4 is of course coming to EOL status on the 28th of this month. I am of course assuming that v12 will include the PHP upgrade as well as everythign else.

As far as I know, Debian Bullseye is still current, and that comes with PHP 7.4.

I don’t know when the new version of Debian (bookworm?) is due but I’d expect the new Sympl to arrive for that.

Does Sympl actually use php for anything? As far as I know, you can run whatever version of php you choose without affecting Sympl. But that’s only my impression of the situation. I may be wrong.

1 Like

My understanding is that Sympl won’t upgrade to v12 until Debian does the same.
Meanwhile, Debian will continue to supply security fixes for PHP7.4 so it’s safe to use, but won’t have the new functionality of PHP8.
There is no official schedule, but past experience suggests mid 2023 for Debian 12.
This seems to happen with every Debian stable release: PHP security support runs out before the new Debian release comes out. It’s not a real problem because of the continuing Debian security support.

Not directly I think, but sympl-phpmyadmin depends on phpmyadmin, and sympl-webmail depends on roundcube, which both use PHP.

1 Like

I use the PHP packages from - and you should be able to install those and move Apache etc over to use the newer PHP variant.

It’s possible you might experience dependency problems with something like roundcube, but as I don’t have it installed, I wouldn’t know.

Thanks all, I understnad now… I didnt realise (forgive me, I dont know how!) that each iteration of Sympl is corresponding with the Debian Version too.

Is anyone using a newer version of PHP with sympl-phpmyadmin and sympl-webmail? If so were there any steps you had to overcome?

I wanted to update this thread:

I have upgraded to PHP 8.1 now. In doing so it broke phpmyadmin and webmail / roundcube.

I have therefore managed to install phpmyadmin myself however im a little more reluctant to do so with roundcube.

Is there any easy step-by-step instructiong to follow on how to get this back up and running please?

This is the error when I go to

Unsupported PHP version. Required PHP >= 5.4 and < 8.0. You might need to manually install the phpX.Y package (for X.Y < 8.0) as well as phpX.Y-{cli,intl,json,mbstring}.

1 Like

The best way to fix this is to revert back to the normal Debian PHP, then run PHP 8.1 or whatever via PHP-FPM, and enable it with an Apache file in /srv/

That way you get the default PHP, as well as the option to swap individual sites to arbitrary PHP versions, and you can do some extra isolation by setting up FPM pools running as different users.

Can you flesh out how best to do this?

There’s a how-to at Alternate PHP Versions - Sympl Wiki which covers it in reasonable detail, although it may be missing automatic updates for me updated PHP packages from that repo.

Thanks. I tend not to remember to look in wikis because they’re mostly a jumble sale of information.