OctoDNS problems

So I decided to try OctoDNS and the setup outlined in the docs by @adhawkins

I first got my test site, distinctlyaverage.co.uk , running via a hostfile edit. Everything looks good and working as expected.

Next task was to point the domain at ns1/2.mythic-beasts.com as it is hosted elsewhere.

I then ran through the OctoDNS setup and this is where the problems started.

When the script runs it does upload something to the Mythic Beasts DNS via the APIv1. The A and AAAA records are there as well as a TXT record for spf1. There is also a second with an RFC1918 address space (172.16/16) which I have no clue where that comes from. The rest of the records are AWOL but they are in the .txt file in the config.

On top of that, after 48hrs since making the change the site is still not showing. It still works via the edited hosts file, but not live in the correct manner. So all I can assume is that the DNS is somehow not correct. Any thoughts appreciated.

Could you perhaps post the output when you run OctoDNS manually? That might help work out where the issue is.

Also, post your OctoDNS config file.


As you can see from the screenshot, there is an odd DNS entry that gets generated ever hou.

Output wise, nothing is displayed when I run sympl-dns-generate

If I run the cleanup script I get

/home/sympl/dns-cleanup.py:18: YAMLLoadWarning: calling yaml.load() without Loader=... is deprecated, as the default Loader is unsafe. Please read https://msg.pyyaml.org/load for full details.
  yamldoc = load(yamlfile)
Cleaning up 'distinctlyaverage.co.uk'
Nothing to delete

If I run the cleanup scrip I get

The config file. Sorry about the odd formatting on here, the bold bits are commented out but the forum seems to interpret those incorrectly.

(edit by @Kelduum: added formatting block)

   class: octodns.source.tinydns.TinyDnsFileSource
   directory: /srv/distinctlyaverage.co.uk/config/dns
   default_ttl: 3600

 #  class: octodns.source.tinydns.TinyDnsFileSource
 #  directory: /srv/subdomain1.distinctlyaverage.co.uk/config/dns
 #  default_ttl: 3600

 #  class: octodns.source.tinydns.TinyDnsFileSource
 #  directory: /srv/subdomain2.distinctlyaverage.co.uk/config/dns
 #  default_ttl: 3600

   class: octodns.provider.mythicbeasts.MythicBeastsProvider
     distinctlyaverage.co.uk.: '*************'

     - config_distinctlyaverage.co.uk
    # - config_subdomain1.distinctlyaverage.co.uk
    # - config_subdomain2.distinctlyaverage.co.uk

     - mythicbeasts

In the end I have reverted to using my registrars name servers and setting dns manually. I must be doing something wrong on the mythic beasts name server as whatever I do it just doesn’t seem to work, whether it was using the failed OctoDNS as per above or entering records manually. So for now I will leave it setup as it is. Hopefully in the future I can get it to work on the mythic beasts side, preferably using OctoDNS . That way I can consolidate my domain registrations all in one place instead of spread over multiple registrars.

For discussion:

I pondered over the exact same issues for a couple of days and even raised some support requests with Mythic. My domains are all registered with 123 Reg rather than Mythic. So, I edited the dns on the 123 Reg side to reflect my MB host but I couldn’t seem to get the dns setup sufficiently to satisfy MX Toolbox.

By way of a trial I installed Sympl on a Bytemark machine and then edited the 123 Reg dns to reflect the Bytemark host and voila we had instant gratification of MX Toolbox requirements in every way. This isn’t my preferred option and sadly it appears I cannot escape Bytemark.

I have a theory that perhaps domains registered with Mythic work seamlessly but not those externally registered.

I think my current setup leverages Bytemark’s content dns system and that’s why it just works?!

Rgds Pete

I too had troubles getting Mythic Beasts DNS to work. So like you I setup my DNS at 123Reg. Took a bit of fiddling of the SPF records but MX toolbox does validate well now so it is possible. Thanks to a tip from @Anahata a while back I used https://www.mail-tester.com/ to test and used its tips to configure my records.

Have you checked your records with MX Toolbox?

Yes, and all is good, as I said in my previous post.