Install Sympl on a Bytemark Debian 10 (Buster) VM

Ahoy there,

I conducted a price comparison between Bytemark and Mythic Beast service offerings a few weeks ago and Bytemark’s prices were more favourable at that time. What a shame Bytemark has discontinued further development of Symbiosis and hence the reason we are being forced to seek alternative solutions. Until I came across Sympl I was seriously considering Virtualmin as a hosting option but it looks as though Sympl will be the optimum way forward thanks to Paul’s hard work. I’m waiting for a bit more product maturity before I use Sympl for production hosting - so I’m currently monitoring the development of Sympl.

I love Bytemark’s cloud hosting products and particularly the following features:

Mature product documentation

E-Z to use control panel

Free backup space

DNS service

Ability to add or remove additional storage discs

Ability to resize system or storage discs

Ability to move discs

Relatively cost effective prices

UK hosted

As I would like to continue taking advantage of Bytemark’s mature and cost-effective infrastructure (because it’s really all I’ve used for the past 10yrs) I’m going to experiment with installing Sympl on a Bytemark Debian 10 server. It’s so easy to generate a cloud server and conduct some testing using the B’mark Ctl Panel. So I’m wondering whether anyone out there has attempted this already? If so, I’d welcome your feedback.

On the topic of backups I guess a cost effective solution would be to host on a Mythic Sympl VM and send backups externally to archive grade storage discs or a private NAS.

Best - Pete

I have installed Sympl to several vanilla Debian builds, and I doubt it would be any different on a Bytemark VM. It’s simply a matter of adding the sources and running the install script.

It should literally just be a case of spinning up a normal Debian Buster install, and then running the Sympl installer - that should deal with any configuration or repositories as needed.

Significantly easier than installing Symbiosis on non-Bytemark systems was!

Not technically a support post, so I’ve got round to creating a new ‘General’ category, and move this here.

If you run into problems though, do feel free to post a new thread in support!

Thank you Paul I’ll give it a go and revert in the event of issues

I’ve installed Sympl on a Brightbox server and it was pretty easy. Had to find a dns host (i’ve gone with and work out their odd (to me) IP address system, however their support has been great and i’ve learnt some stuff :slight_smile:

So I pretty much answered my own question today by installing Sympl on a Bytemark Buster cloud server. The installation went smoothly with only the following prompt:

‘A new version (/tmp/filetLiHuo) of configuration file /etc/ssh/sshd_config is available, but the version installed currently has been locally modified.’

Not knowing the answer I opted to install the package maintainers version albeit I’m currently unsure whether this was the correct course of action?

What a bummer phpMyAdmin doesn’t come with Buster, however I think I’ve managed a successful installation but I have yet to test. I’m planning to install Munin when I have a moment for quick and E-Z web browser monitoring.

I decided to host Sympl on a Bytemark cloud server to take advantage of their flexible infrastructure, cost effectiveness and Bytemark’s content DNS system (DNS magic just happens at Bytemark). The Sympl roadmap promises to include OctoDNS plus a raft of other goodies - that said my problem is that I’m far too impatient.

Installed: (none)
Candidate: 4:4.9.5+dfsg1-2~bpo10+1
Version table:
4:4.9.5+dfsg1-2~bpo10+1 100
100 Index of /debian buster-backports/main amd64 Packages

Bit weird it’s not available in non-backports for buster.

Welcome, @DavidGoodwin!

The package was missing a maintainer for a while before Buster was released, so missed release, but since then it was picked up so it’s been added to the backports repo and will be in the next version.

However, the Debian policy is not to add ‘new’ packages once a release is final so you’d need to add the backports if you wanted to install it.

Understood and that’s great news :+1:

Hi there

Very new here. Just wanted to say (and I am not very technical) that I installed Sympl on Debian 10 at Bytemark after my Symbiosis 9 Wordpress site started throwing up "Your PHP is out of date errors.) I contacted support and was told that Symbiosis will probably not be further developed but I could try Sympl.

I managed to get it to work after three attempts (easy to reimage servers at Bytemark and start again :slight_smile: ) and I was able to move all my small wordpress sites to Sympl.

I also noticed that the installation had BytemarkDNS but it was empty. I copied the upload script from the symbiosis server to the sympl server and tested manual updates.

Fingers crossed, everything seems to be working so far and the sympl wordpress install was so fast that the only slow part was copying the wordpress files over.

Thank you to the developers of sympl.


1 Like

Did you try to reimage with the Bytemark “Buster with Sympl” image? I tried that, twice. Didn’t work.
The standard Buster image was fine, though.
I’ve not tried the DNS uploads on Bytemark again yet: if it’s working for you, perhaps I’ll try it.

Word of caution!

Careful if using the DNS uploads script. It’s possible to inadvertently delete dns files from your dns account that are relevant to domains hosted on other Bytemark machines - well should you have any!

After loading sympl to a Bytemark buster vm I chose to set the dns via the 123 Reg Panel to avoid any potential gotchas.

Hi Hairydog

I loaded the Debian 10 image. There are no sympl images on Bytemark.


Hi compassweb

having this problem right now as I write. I was copying the changes to my symbiosis server and running the script from that server. I deleted the symbiosis server and now running the upload script from the new sympl server. It is not working :frowning:


I think you need to contact their support to have the DNS auth moved from one machine to the other. Or something?


I told Bytemark Support that the sympl buster image was broken. I expect they removed it.

I have had some very bad experiences of 123-reg DNS servers. I’d not use them for anything. LCN seem OK, but perhaps 123-Reg got better: after all they’re still in business!

I had same issue so contacted Bytemark support for advice. As I have multiple machines, they advised that I didn’t run the script so I resorted to using 123 Reg dns to keep everything simple. That said I’m looking forward to trying OctoDNS when it becomes part of Sympl.

If you’re looking for domain hosting/registration, I’d personally suggest my employer (and sponsor of Sympl) Mythic Beasts.

There is a web interface as well as an API if you want to do anything complex, easy to use support for the more complex things like DNSSEC, and of course support for OctoDNS.


1 Like