Fresh install fails no pubkey for backports

Problem Description

I’m trying to do a fresh install on Pi4 but can’t because backports isn’t signed.

I suspect that backports is only there for phpmyadmin (which I don’t need), so how can I run the install without it?

For now, I added [trusted=yes] to the line in enable_backports.list but it’s not ideal

Any Error Messages

Installing initial dependencies…
W: GPG error: Index of /debian buster-backports InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138
E: The repository ‘Index of /debian buster-backports InRelease’ is not signed.


  • Sympl Version [/10.0]:
  • Sympl Testing Version? [Yes/No] tried both
  • Debian Version [Buster/]:
  • Hardware Type? [Pi]
  • Hosted On? [name of hosting co]lan

I’ve not managed to find backports for Raspbian. I don’t think that you should be looking at a repo.

I’m taking a look at this now, but you should be able to use the manual install progress in the mean time if it’s urgent: Installing Sympl - Sympl Wiki

It installed OK after I added [trusted=yes] to the backports entry, though it did show a warning message.
To be honest, I never checked to see if phpmyadmin works. But I suspect it will

I’ve pushed an update now, so all should be okay again.

The problem was due to checking for Buster in general, rather than specifically for Debian only, so a check for that means it’s now happy.