Email forwarders and Gmail

Problem Description

I have a forwarder set up on a mailbox. I’m getting inconsistent delivery to Gmail accounts. Error message below. I have SPF and DMARC set up but it doesn’t seem to have helped. Will forwarding work at all for this situation?

Any Error Messages

2023-01-20 12:24:55 1pIqRz-00GThc-Jh ** R=dnslookup T=remote_smtp [ipv6 address of my server] X=TLS1.3:ECDHE_X25519__ECDSA_SECP256R1_SHA256__AES_256_GCM:256 CV=yes: SMTP error from remote mail server after end of data: 550-5.7.1 [ipv6 address of my server] Our system has detected that this message does\n550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and\n550-5.7.1 authentication. Please review\n550-5.7.1 for more information\n550 5.7.1 . k4-20020a05600c168400b003d976e09663si1761778wmn.23 - gsmtp


  • Sympl Version: 11.0
  • Sympl Testing Version? [No]
  • Debian Version [Buster/Stretch]: Bullseye
  • Hardware Type? Virtual
  • Hosted On? Mythic Beasts

Welcome @tim_vaughan!

Forwarding to Gmail tends to be a problem no matter what you do, as they treat the sending IP as suspicious if any forwarded mail fails SPF, and will tend to silently drop things (or throw them in spam).

You’re much better off creating a mailbox and sending the mail to that, then using Gmails “collect mail from other accounts” options to pick up that mail via POP3 - that means they treat the mail as if it was received directly at the normal email address of the Gmail mailbox, complete with the typical spam filtering, as well as optionally being able to send from the mailbox also.

However, the actual error message…

Our system has detected that this message does
 not meet IPv6 sending guidelines regarding PTR records and
 authentication. Please review for more information

Suggests you might not have a PTR record set up for the IPv6 address of your server - for Mythic you can set that via the control panel under the DNS section, and you should be fine to set it to the default domain, usually something like <server_id>

1 Like

Hi, thanks - appreciate the help. I’ve set up a normal mailbox and have configured access via POP.