Problem with zz-mass-hosting.ssl.conf

As a heads-up, had a problem with one of our Buster servers last night at pretty much bang on midnight when it stopped responding to http/https requests (not sure if thats when sympl updates would roll out?)
I’m struggling to work out the exact issue, and it’s only affected one server so far out of about 10. (I do know this server still looks to be running mod-php rather than fpm, the other servers are probably all fpm. We haven’t changed anything on the site for probably best part of a year)

I’ve narrowed it down to apache disliking zz-mass-hosting.ssl.conf for some reason - if i run apachectl configtest it says the syntax is okay, if i restart apache it bails with it in use (and annoyingly can’t see a reason why in the logs other than it just exits). If i unlink zz-mass-hosting.ssl.conf from sites-enabled then apache’s happy to start again (seems okay with the non-ssl version, which suggests maybe something to do with ssl).
Would anything have changed with zz-mass-hosting.ssl.conf in the latest release?

Can’t see anything obvious amiss in it’s vhost entry, and as i said it passes configtest so i’m at a bit of a loss as to what’s up with it (we don’t actually use the zz-mass-hosting so I’ve just removed it from sites-enabled to get the site up and running again) :man_shrugging:

(Just to mention, I’ve split this into it’s own topic under support, and contacted @tricky for some more info to see if I can identify the issue, although I don’t think it’s related to the other recent issue with new installs.)

mmm I seem to have this exact same issue also - started over the weekend…
I have an old install too running on iomart which I’ve been meaning to move for a while…

Have you tried the fix mentioned here?

What version of Debian are you running. And was it imaged from one of the Bytemark images, upgraded from older Debian or were you given some command to install an image from elsewhere?

I’ve not been able to confirm it, but have a feeling some of the non-directly imaged VMs may have an issue.

On this server, Debian 10 and was historically on Bytemark’s servers, then moved to iomart… I haven’t been able to run any sympl updates, with dpkg errors like:

sympl-core.service: Failed to set up standard output: Inappropriate ioctl for device
sympl-core.service: Failed at step STDOUT spawning /etc/init.d/sympl-core: Inappropriate ioctl for device

I’ve started a new VPS with Hostinger using Debian 11 but have also run into problems there, sympl-monit reporting apache2: FAILED Internal software error…

The “Inappropriate ioctl for device” error suggests you don’t have the typical environment on the shell, as if the commands are being executed as root. Are you SSHd in or using some other interface?

I assume it’s not got any data on it, so would I be possible to get access to the hostinger server temporarily to take a look? I’ll message you directly.

Thanks… The iomart issue I think is related to the move from Bytemark and I’ve been planning to migrate and leave at some point anyway…

I’ve just noticed the Hostinger Debian 11 build uses the old 4.19 kernel if that could be an issue?
I’ve tried their Debian 10 build with Sympl 10 but the output of sympl-monit is giving this:

Tests started at 2023-11-09T20:39:50+00:00.

  • apache2: FAILED: exit 1
  • cron: FAILED: exit 1
  • mysqld: FAILED: exit 1
  • pure-ftpd: FAILED: exit 1
  • sshd: FAILED: exit 1

Tests finished at 2023-11-09T20:39:51+00:00.

I can reimage again if you’d like to test?

It sounds like these are containers, rather than proper virtual machines (with their own disks, BIOS, etc), especially with Debian Bullseye on a 4.19 kernel.

From what I can tell the iomart setup isn’t entirely full VMs (ie: typical boot times, BIOS, install from ISO, etc), and I’m not confident their ‘migrations’ went as planned as they seemed to have halted them with no further info on migrating users.

Looking at the Hostinger site, it may be a similar container-based thing there also (at least for their VPS product).

If you want to reimage and send me credentials via a PM, I can take a quick look.

As a side note, I thought this may have been a dependency issue, with a missing package in some images, but having imaged VMs with Debian 10 and 11 netboot images with nothing included, everything at least seems to work as expected.

Thanks for giving me access!

Just to answer this publicly for anyone else who may come across it, that looks to be because the Hostinger VPSs are actually containers running on a Redhat host, and are missing a few standard Debian packages like dbus (you can install it manually with apt install dbus). I’ll add that to the dependences for sympl-core, but you’re likely to run into other issues.

Apart from that, while things are mostly configured as normal, Sympl doesn’t seem to be able to get the IPs on the network interface - this is old Symbiosis code so I’ll need to look into how it’s trying to query things, and there are ways around it to get web services up and running, but things like sympl-firewall aren’t going to work by default.

If anyone else encounters this issue, you’re probably best looking at a full VM in the medium to long term until this can be identified and changes made to Sympl to support it.

As always, I’d suggest Mythic Beasts virtual servers, as they’re full VMs similar to the old BigV setups, running stock Debian images, and they provide a great deal of support to the project!

1 Like